How to Make Foxit Reader Work in Ubuntu 12.04 & 11.10 Oneiric Ocelot?

Foxit reader is a pretty good alternative PDF reader, if you’re a bit dissatisfied with the default one that comes with Ubuntu called “Evince”. Now few months ago, I wrote a post about how to install it in Ubuntu.

However, back then I used Ubuntu 11.04 Natty Narwhal (as it was the “hot release” those days :D) but thanks to a comment by “Nidhi” in that post I just realized that it doesn’t seem to work in Ubuntu 11.10 Oneiric Ocelot. I don’t know why, but for some reason, when you double click on the “.deb” file of Foxit in Ubuntu 11.10, Ubuntu Software Center, although the progress bar shows a 100% completion yet it doesn’t seem to get installed properly at all.

Now by default, after successfully installing a package, the “Install” button in Ubuntu Software Center should change into “Reinstall”, indicating that the app has successfully installed. But even after installing the Foxit (again, after the progress bar showing a 100% completion), that button still says “Install”, which is an indication that the installation was performed partially (if not installed at all).

So, after the installation, if you search in the Unity’s Dash for “foxit”, it’ll even display the program’s icon … however, when you click on it, noting happens, because the main Foxit executable file (more below) is missing due to the partial installation.

Foxit-icon-showing-in-Unity-Dash
Well, you can click the heck out of it, nothing would happen though ๐Ÿ˜› …

But the thing is, it can be easily fixed. So before going into further details, let’s do it.

Update (06/09/2012): These steps also works under Ubuntu 12.04 too.

1. First, download the official Foxit “.deb” file from this official download page (this issue is with the Foxit version “1.1.0”).

Update: This link doesn’t work anymore, but it’s still available to download. For that please visit this page and then under the ‘Foxit Reader’ sub-heading click on the drop-down menu and choose ‘Desktop Linux’. Then click ‘Free Download’ and from the next pop-up window, under ‘Package Type’ choose ‘Deb’.

Update 2015-August: The above link is also now gone!. But fear not, it’s still on the official Foxit mirror. You can download it from hereย (make sure to make a backup of it, who knows, Foxit might delete it too in the future).

2. Once the download finishes, double click on the file. It should open Ubuntu Software Center and then click on the “Install” button to install it.

As said before, just don’t worry about the “Install” button not changing into “Reinstall”. After the installation, close the Ubuntu Software Center (but make sure to click on the “Install” button at least once and the progress bar shows a 100% completion, so it has installed it, even if it’s partial).

3. Now go to the downloaded Foxit “.deb” file’s location and right click on it.

From the menu choose, “Open with Archive Manager”, as shown below.

opening-with-Archive-manager

This should open-up the file in the Archive manager and should display the actual content of the file as shown below (this is because a “.deb” file is sort of a file archive format).

foxit-deb-file-content

4. Now double click on the folder called “usr” which should open the content of that folder.

entering-the-usr-folder

Then from the next window (shown below), again double click on the file called “bin”.

entering-the-bin-folder

Once inside that “bin” folder, you’ll see a file called “FoxitReader”. This is the main execution file of Foxit reader itself, and is also the one that doesn’t get copied/installed into HDD for some reason. What we’re going to do is quite simple. We’re gonna manually copy this file to the default location (“/usr/bin”) in your HDD which should solve our problem.

5. Now, select that file, and right click on it. From the menu choose “Extract”.

You can extract this to anywhere, but to keep things simple, please extract the file into your “Home” folder.

extracting-the-executable-file

6. Once that’s done, open your Terminal window and simply issue the below command.

sudo cp FoxitReader /usr/bin

After that’s done, simply search for “foxit” in Unity’s Dash (or in Nautilus context menu after selecting a PDF file), and click on its icon, and voila!, now it should open the Foxit reader as it’s supposed to ๐Ÿ˜€ (shown below). That’s it!.

Foxit-PDF-reader-running-in-Ubuntu-11.10
A little proof to show you that Foxit is running under Ubuntu 11.10 ๐Ÿ˜‰ …

If you have extracted the “FoxitReader” file to somewhere else other than your “Home” folder, then please use the proper file path in the above command (“/your-folder-path/FoxitReader”).

*Update (05/11/2012), only for the Ubuntu 64-bit users:

If you use the 64-bit version of Ubuntu (12.04, 11.10 etc), then even after doing all this, “Foxit” still won’t work. That’s simply because, Foxit only has a 32-bit version and for an any application that’s created to run under 32-bit processor instructions should undergo few changes in order to support the 64-bit instructions.

But you can install a special software library that “fakes” (emulates) a 32-bit processor using your actual 64-bit CPU and the program should run without issues. In Ubuntu (plus, GNU/Linux in general), we need a library called “ia32-libs” for that.

It could be because this library has a shi* load of dependencies ๐Ÿ˜‰ (needs a lot of individual packages, about 70-80MB to download), Ubuntu does not come with it pre-installed.

So, for all ya 64-bit users, after following all the above steps, there’s this one last step that you gotta do before you can enjoy our naughty little “Foxit”, and that is installing this software library. For that, open your Terminal window and enter the below command.

sudo apt-get install ia32-libs

That’s it, now it should work. A big thanks goes to “robert” (in the comment section), couldn’t have done it without you mate!, thank you :D.

But as this needs a lot of libraries (somewhat an “unnecessary burden”, if you won’t really be running 32-bit apps in 64-bit Ubuntu that is), unless you really can’t live without “Foxit”, I humbly suggest that you try something else, “qpdfview” for instance?. *

Update (07/12/2013): According to ‘Joe’ (comments) Ubuntu 13.10 users also have to install two additional packages. You can install them by entering the below command (Note: I did not test to see if they’re actually necessary or not).

sudo apt-get install libgtk2.0-0:i386 libstdc++6:i386

Oy Gyan!, BTW, why did the default Foxit “.deb” installation fail?

I honestly don’t know. But then again, that “.deb” file was last released more than two years ago!, so perhaps it’s some sort of an incompatibility issue.

Anyhow, if you’ve been having troubles properly installing or running Foxit PDF reader in Ubuntu 11.10 Oneiric Ocelot or 12.04 Precise Pangolin then that’s one way to fix it (hopefully ;-)). Enjoy!.

An RHCE, 'Linux' user with 14+ years of experience. Extreme lover of Linux and FOSS. He is passionate to test every Linux distribution & compare with the previous release to write in-depth articles to help the FOSS community.

135 thoughts on “How to Make Foxit Reader Work in Ubuntu 12.04 & 11.10 Oneiric Ocelot?”

Leave a Comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.

0 Shares
Tweet
Share
Share
Pin