How to Install LibreOffice 3.4.4 in Ubuntu 11.10 Oneiric Ocelot?

LibreOffice is an awesome opensource office productivity suite which was introduced as a result of some of conflicts that took place around the previous OpenOffice suite. Starting with the 11.04 Natty Narwhal release, Ubuntu too replaced it with OpenOffice.

Although Ubuntu’s application indicator menu always had its issues with LibreOffice and as a result in Oneiric, Libre runs without the proper menu support but it’s still the major office productivity suite that’s being used by the GNU/Linux OS. Few days ago the documentation foundation released a new version of LibreOffice 3.4.4 that brings few enhancements and bug fixes as usual such as:

More language support, PDF related memory leak fix, Qt related UI fix, document crashing with footnotes fix… you can read the full fixed bugs from this page and this page.

But the thing with Ubuntu is, unless you’re prepared to install it manually, other than the latest 11.10 users, others just can’t install it using the easy way (PPA channel).

You can install LibreOffice 3.4.4 in Ubuntu 11.10 Oneiric Ocelot by simply adding the test-builds PPA by using the below commands.

sudo apt-add-repository ppa:libreoffice/ppa

sudo apt-get update

sudo apt-get install libreoffice

That should do the trick.

Oy Gayan!, how can we install it in Ubuntu 10.10, 10.04 and 11.04 Natty Narwhal?

Well, you can try to manually install in in those Ubuntu machines by using the below steps.

1. First remove the OpenOffice (concerning 10.10 and 10.04 users or even if you have it manually installed) by using the below command.

sudo apt-get purge openoffice

2. For the 11.04 users, you gotta remove the existing LibreOffice too. For that use the below command.

sudo apt-get purge libreoffice

3. Then download LibreOffice 3.4.4 from this page (32bit) and this page (64bit) and extract the content (say to your “Desktop” for example).

4. Now open your Terminal and change the directory into that extracted folder. And simply issue the below command.

sudo dpkg -i *.deb

5. Now use the below command to properly integrate it with your desktop settings.

cd desktop-integration

6. Now the final step. Again use the below command.

sudo dpkg -i *.deb

Yup, that’s it.

If everything went according to plan then you should have LibreOffice 3.4.4 in those now “old” Ubuntu versions!.

A warning though, I didn’t test this so I don’t know whether it works or not… so use it your own risk. If something bad happens, then you can always install LibreOffice from the official Ubuntu repositories by using the below command.

sudo apt-get install libreoffice

Leave a Comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.

%d bloggers like this: